ISIS 7 install error

Hi there,
I get an error when trying to install isis7 using conda
OS: Ubuntu 18.04 LTS

Here is the error (perhaps there is an issue with the glibc version check?):
conda install -c usgs-astrogeology isis=7.0.0
Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: -
Found conflicts! Looking for incompatible packages. failed

UnsatisfiableError: The following specifications were found to be incompatible with each other:

Output in format: Requested package → Available versionsThe following specifications were found to be incompatible with your system:

  • feature:/linux-64::__glibc==2.27=0
  • feature:|@/linux-64::__glibc==2.27=0
  • isis=7.0.0 → mesalib → __glibc[version=’>=2.17,<3.0.a0’]

Your installed version is: 2.27

I am able to install isis 6.0.0 but both 7.0.0 and 7.1.0 give this error.

commands run:
conda create -n isis python=3.6
conda active isis
conda config --env -add channels conda-forge
conda config --env -add channels usgs-astrogeology
conda install -c usgs-astrogeology isis=7.1.0

Has something changed in the install steps needed between 6 and 7 versions?

We made some significant changes to the dependencies in ISIS 7.0. Try installing ISIS 7.0 or 7.1 into a fresh environment. Note that you no longer specify a Python version when creating the environment.