ISIS installation problem

I encounter the following problem while trying to install ISIS on Ubuntu 20.04.4 LTS

(base) $ conda activate isis
4.3.0 # Public version number
2020-10-28 # Release date
stable # Release stage (alpha, beta, stable)
(isis) $ conda config --show channels
channels:
  - usgs-astrogeology
  - conda-forge
  - defaults
(isis) $ conda install -c usgs-astrogeology isis=7.0.0
Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: / 
Found conflicts! Looking for incompatible packages.
This can take several minutes.  Press CTRL-C to abort.
failed                                                                                 

UnsatisfiableError: The following specifications were found to be incompatible with each other:

Output in format: Requested package -> Available versionsThe following specifications were found to be incompatible with your system:

  - feature:/linux-64::__glibc==2.31=0
  - feature:|@/linux-64::__glibc==2.31=0
  - isis=7.0.0 -> mesalib -> __glibc[version='>=2.17,<3.0.a0']

Your installed version is: 2.31

Try removing the defaults channel and then installing again. You can check your channels with conda config --show channels and then remove defaults with conda config --remove channels defaults. You may need to remove it from your environment config instead with the --env flag.

@jessemapel Okay. After config --remove channels defaults the defaults channels is still there and the same error occurs.
What do you mean with “You may need to remove it from your environment config instead with the --env flag”? (I am not familiar with conda.) Thanks.

It seems like we cannot remove defaults from the channel search. Try this command to install ISIS conda install --override-channels -c conda-forge -c usgs-astrogeology isis=7.0.0 and avoid using defaults

@jessemapel Okay, after this it gets stuck at the same place, but with one fewer error message.

(isis) ~$ conda install --override-channels -c conda-forge -c usgs-astrogeology isis=7.0.0
Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: | 
Found conflicts! Looking for incompatible packages.
This can take several minutes.  Press CTRL-C to abort.
failed                                                                                                               

UnsatisfiableError: The following specifications were found to be incompatible with each other:

Output in format: Requested package -> Available versionsThe following specifications were found to be incompatible with your system:

  - feature:/linux-64::__glibc==2.31=0
  - isis=7.0.0 -> mesalib -> __glibc[version='>=2.17,<3.0.a0']

Your installed version is: 2.31

Meanwhile, I upgraded from Ubuntu 20.04 LTS to 22.04 LTS. I get similar errors:

(base):~$ conda activate isis
4.3.0 # Public version number
2020-10-28 # Release date
stable # Release stage (alpha, beta, stable)
(isis) ~$ conda config --show channels
channels:
  - usgs-astrogeology
  - conda-forge
  - defaults
(isis) norbert@arsia:~$ conda install -c usgs-astrogeology isis=7.0.0
Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: | 
Found conflicts! Looking for incompatible packages.
This can take several minutes.  Press CTRL-C to abort.
failed                                                                                           

UnsatisfiableError: The following specifications were found to be incompatible with each other:

Output in format: Requested package -> Available versionsThe following specifications were found to be incompatible with your system:

  - feature:/linux-64::__glibc==2.35=0
  - isis=7.0.0 -> mesalib -> __glibc[version='>=2.17,<3.0.a0']
  - python=3.6 -> libgcc-ng[version='>=9.3.0'] -> __glibc[version='>=2.17']

Your installed version is: 2.35

The basic problem is that the ISIS installation is compatible with Ubuntu 18.04 LTS and not 22.04 LTS. Blessed are those who haven’t upgraded their operating system in four years.