MRO-MARCI image processing

I am trying to process MARCI images using ISIS. I gave a trial run on a single image from MARCI to check whether the isis environment and the functions were properly working or not. So, I just tried the marci2isis function to convert the pds image to an ISIS cub file. There I got a warning mentioning “No variable exposure information found…”. But the function was able to successfully split the image into odd and even cub files. When I checked the stats of those cub files, I found that almost 50% of the pixels showed null pixels (It is expected as the mode is showing 0.0). Also, the standard deviations were quite high compared to the mean values(eg S.D of 29.8 for a mean of 52.6). So, I am not sure whether the marci2isis process was actually successful or not. I tried the mroctx2isis command for processing a ctx image to a cub file later. There was no warning and there were no null pixels there. If anybody can clarify this, it will be a great help.

Also, I then tried to attach SPICE data to the cub files. But I got an error saying “No existing files found with a numerical version matching …” . I downloaded the MRO mission data using rsync server before starting the image processing. I think there are some missing kernels that may have resulted in this error. I shall try downloading the MRO data from the rsync server again and give it a try again though. Please share your thought also.