Problems while installing isis

Hi there,

I do have a couple of questions/problems concerning ISIS and Ames Stereo Pipeline following (ASP) and was wondering if someone could help me with those. I’m very new to all of this but I hope someone here has some tips for me?

My goal is to generate DTMs of Mars using HiRise Images. I did set up a WSL (WSL1) and managed to install ASP following the documentation. Then I tried installing ISIS, following the ISIS guide on GitHub. I think everything was alright until I reached the ISIS Data Area part, because I couldn’t download the right ISIS data package (“command not found”) and noticed that the downloadIsisData.py script was missing. Looking through the issues on GitHub I found a fix for that and downloaded the script, adding it to the script folder in my ISIS environment. But the MRO data package is >200GB? Can that be true? I’m wondering because the whole ISIS Data package was said to be 520GB? I can’t download and store that amount of data, that’s why I tried to use the SPICE Web service. But I must say I have no idea how to implement that in my ISIS Data Area. I did try these commands:

cd $ISISDATA

rsync -azv --exclude=‘kernels’ --delete --partial isisdist.astrogeology.usgs.gov::isisdata/data/mro .
rsync -azv --exclude=‘kernels’ --delete --partial isisdist.astrogeology.usgs.gov::isisdata/data/base .

following the guide and did download something. There are two tutorials documented in the ASP Guide, the first one runs without a problem, so I believe ASP is properly set up. But I can’t complete the second tutorial, I am running into an error already with the first command, “mocproc”.

This is what I’m running:

mocproc from=E0201461.imq to=E0201461.cub Mapping=NO

And this is the error:

QProcess: Destroyed while process ("/home/othello/miniconda3/envs/isis/bin/moc2isis") is still running.

ERROR PVL Keyword [Class] does not exist in [Group = Error].

There is an output generated but it doesn’t seem right?

I listed everything I did because I’m not sure where I went wrong. Does anyone have any experience with these problems?

Hi, you will need to download the MGS data to use mocproc.

cd $ISISDATA

rsync -azv --exclude=‘kernels’ --delete --partial isisdist.astrogeology.usgs.gov::isisdata/data/mgs .
1 Like

Thank you for the quick reply! I did that, unfortunatly I am still getting the same error…

This looks like the same error https://github.com/USGS-Astrogeology/ISIS3/issues/4916

The mocproc program is just several other programs strung together, can you try running them individually.

  1. moc2isis from=E0201461.imq to=E0201461.cub
  2. spiceinit from=E0201461.cub
  3. moccal from=E0201461.cub to=E0201461_cal.cub
  4. mocnoise50 from=E0201461_cal.cub to=E0201461_noise.cub
  5. mocevenodd from=E0201461_noise.cub to=E0201461_final.cub
1 Like

Thank you for your help and sorry that I’m only answering now. I did that and got the same error from the threat you posted. My ISISDATA variable is set properly but it seems like I’m missing the proper kernels. The commands I used earlier to download the data explicitly exlude kernels, why am I doing that if I need them? I did download the kernels for the “base” data, but I’m afraid I’ll need the kernels for “mro” and “mgs” as well. “mocproc” is running and I do get a proper output now but the values seem a little bit off.

At what step did you get the error?

I got an error while running moccal, apparently I was missing a naif file? I did repeat this download:
rsync -azv (–exclude=‘kernels’) --delete --partial isisdist.astrogeology.usgs.gov::isisdata/data/mgs . but left out the --exclude=‘kernels’ part of it. After that I tried running mocproc again and it worked. I used point2dem to create a DEM but the values seem off to me. Cellsize seems to be 0.000073 and the elevations also don’t seem to be right.
And while running the mocproc programs seperatly again I got this error for running mocnoise50: USER ERROR The 50 sample noise pattern does not occur in MOC narrow angle images with crosstrack summing greater than one.

Glad to hear it worked for you. It’s not uncommon for some of the older calibration programs to require kernel data to compute things like solar distance.

I can’t help with the point2dem issues as that’s ASP and I am not familiar with it.

The mocnoise50 error, just means it is not required for your data. The last 2 programs are only run in specific situations. It looks like your image is summed, so you don’t need to run mocnoise50 or mocevenodd.

2 Likes

Hey Jesse, thank you so much for your help! I think I’ll leave the ASP tutorial for now and see if I can get a proper DEM from HiRISE Images. I did download EDR products of stereo pair and tried running hiedr2mosaic.py which didn’t work. That script combines several programs, right? It seems like the error occured while running hical and looks like this:
USER ERROR Failed in GainUnitConversion module.
USER ERROR Unable to determine the distance from the target to the sun.
ERROR No existing files found with a numerial version matching [MRO_SCLKSCET.???.65536.tsc] in [/home/othello/isis_data/mro/kernels/sclk].
It seems like I am missing a kernel again? Will I have to download all the kernels for mro and mgs as well to process HIRISE images? And if so, what does the Web Service actually do and/or how can I implement it? Or will I need all the ancillary data localy?

We’ve tweaked some of the calibration apps to require either local SPICE, or a spiceinit’d cube. Previously they required the SPICE data to be local. So, if you run spiceinit, with the SPICE web service, on the cubes before hical it should fix your problem.

For context, the SPICE web service takes all of the SPICE data for the image and sends it over the internet, which is then attached to the cube file. Many of the calibration programs were created before this existed, so they just assumed you have all of the SPICE local. We’ve since gone back and added the ability to use attached SPICE.

Thank you for the explanation Jesse! I altered the hiedr2mosaic.py script a little bit to run spiceinit before hical and use the web service as well. Do you think that is something of interest for others as well?

Yes, if you’re going to run both spiceinit and hical, it is recommended to run spiceinit first now. The same is true of the following calibration programs as of ISIS 5.0.0:

amicacal, ctxcal, lrowaccal, moccal, mdiscal, hical, hicalbeta, vikcal, and gllssical