Requiring OPENSSL when installing isis from mamba

Hi there,

I tried to install ISIS for the first time. I followed the instruction guide from GitHub - USGS-Astrogeology/ISIS3: Integrated Software for Imagers and Spectrometers v3. ISIS3 is a digital image processing software package to manipulate imagery collected by current and past NASA and International planetary missions. on my Ubuntu 18.04.6 LTS 64bit machine. It went really well until Mamba tried to download ISIS and its dependencies. The error is that “Problem: package python-3.6.13-h12debd9_1 requires openssl ≥=1.1.k,<1.1.2a, but none of the providers can be installed”.

Any insight to this error? Thanks in advance!

I’ve experienced the same issue on a Windows Subsystem for Linux (WSL).
Although openssl seems to have been already installed (openssl 1.1.1m). After uninstalling openssl completely by running
mamba uninstall openssl
it seems like mamba was able to solve this problem.
I could then install isis4 with

 mamba install -c usgs-astrogeology isis

Not sure if what I’ve tried before also was necessary, but I’ll document it here:

conda activate base
conda update conda -c conda-forge
conda update mamba -c conda-forge

However, when I finish the installation following the webpage you already inserted, and want to run a program (e.g. mapmos), it returns:

mapmos: error while loading shared libraries: cannot open shared object file: No such file or directory

If the same happens if you try this, it is probably an issue of openssl, else, it might be related only to my installation in the WSL.

This appears to be a bug in the mamba environment solver.

For right now, we recommend using the standard conda solver. It will take much longer to solve, but it shouldn’t raise this error.

See Python requires openssl package that I already have installed. · Issue #4778 · USGS-Astrogeology/ISIS3 · GitHub for more information.